360°-Bilder importieren & anzeigen (Beta)

Dieser Artikel beschreibt, wie Sie 360°-Bilder in Cintoo importieren, sofern diese 360°-Bilder georeferenziert sind und sich im selben Koordinatensystem wie die 3D-Scans befinden.

Berechtigungen: Nutzer mit Rollen, die die Berechtigung Importieren oder Löschen der Reality Data enthalten, können 360°-Bilder mit Cintoo Connect importieren, bearbeiten und löschen.

INHALTSVERZEICHNIS


Beta-Funktion

Dies ist seit dem 14. Dezember 2020 eine Beta-Funktion. Da es sich um eine Beta-Funktion handelt:

  • Der Zugriff steht allen Cintoo-Abonnenten zur Verfügung.
  • 360°-Bilder werden bei der Scananzahl nicht als Scans mitgezählt
  • Die maximale Anzahl an 360°-Bildern, die in Cintoo hochgeladen werden können, ist auf die im Abonnement enthaltene Scananzahl begrenzt.
    Bei einem Abonnement für 5000 Scans können beispielsweise bis zu 5000
    360°-Bilder hochgeladen werden.
Warnung: 360°-Bilder sind ausschließlich 2D, daher ist es nicht möglich, mit ihnen Anmerkungen (die mit einem 3D-Punkt verknüpft sind) hinzuzufügen oder Messungen durchzuführen. Sie dienen nur der Anzeige.

Schritt 1: 360°-Bilder vorbereiten

360°-Bilder müssen zusammen mit einer CSV-Datei, die Informationen zu Position und Ausrichtung jedes Panoramas enthält, in einem einzigen Ordner gespeichert werden. Die erwarteten Formate sind die folgenden:

Alle 360°-Bilder müssen sphärische Bilder im Format JPEG oder PNG sein. Beispiel für ein sphärisches Bild.

 

Derselbe Ordner muss eine CSV-Datei enthalten, die den Namen des 360°-Bilds (mit Dateierweiterung), die Position und die Ausrichtung für jedes 360°-Bild enthält.

Die CSV-Datei muss wie folgt aufgebaut sein:

  • Verwenden Sie das Komma „,“ als Spaltentrennzeichen
  • Die Spalte für den Dateinamen muss filename heißen
  • Dateinamen sollten ihre Dateierweiterung enthalten (.jpg oder .png)
  • Benennen Sie die Spalten für die Position x, y, z
  • Die Werte x, y, z müssen in Projektmesseinheiten und im selben Koordinatensystem wie die Scans angegeben werden
  • Die Ausrichtung muss als Quaternion oder als einfacher Heading-Wert angegeben werden

 

Hinweis: Da sowohl die Quaternionen-Notation als auch Heading als Ausrichtung unterstützt werden, ist es nicht möglich, Heading und Quaternion in derselben CSV-Datei zu verwenden. Es gilt entweder das eine oder das andere, andernfalls lehnt Cintoo Connect die Datei ab.

Quaternionen zur Ausrichtung verwenden

  • Benennen Sie die Spalten qw, qx, qy, qz
  • Auf diese Weise sollte die erste Zeile wie folgt aussehen (die Reihenfolge spielt keine Rolle): filename, x, y, z, qw, qx, qy, qz
  • Bei Quaternionen gilt für „keine Rotation“: qw = 1 und qx = qy = qz = 0

Heading-Wert zur Ausrichtung verwenden

Erstellen Sie in der CSV-Datei eine Spalte mit dem Namen heading.

Der Parameter Heading gibt den Winkel in Grad an, als Rotation um die Z-Achse. In der Draufsicht steht ein positiver Winkel für eine Drehung im Uhrzeigersinn (in Richtung Osten).

 

Hinweis: Bei Verwendung von Heading wird keine Rotation um die X- oder Y-Achse angewendet. Wir gehen davon aus, dass die 360°-Bilder vertikal korrekt ausgerichtet sind (die Ebene durch die „Äquator“-Linie muss parallel zur XY-Ebene verlaufen), andernfalls wirkt das Bild schief (ein gerades Gebäude würde geneigt erscheinen).

 

Der Winkel bezieht sich auf die Bildmitte und die Nordrichtung:

  • Ein Heading von 0 Grad bedeutet, dass der Nutzer die Bildmitte sieht, wenn er nach Norden (+Y) blickt.
  • Ein Heading von 90 Grad bedeutet, dass der Nutzer die Bildmitte sieht, wenn er nach Osten (+X) blickt.
  • Ein Heading von 180 Grad bedeutet, dass der Nutzer die Bildmitte sieht, wenn er nach Süden (-Y) blickt.
  • Ein Heading von 270 Grad bedeutet, dass der Nutzer die Bildmitte sieht, wenn er nach Westen (+X) blickt.

 

Hinweis: Die Navigationskarte in der unteren rechten Ecke hilft dabei, herauszufinden, in welche Richtung ein Nutzer aktuell blickt.

Schritt 2: 360°-Bilder mit Cintoo Connect hochladen

Verwenden Sie Cintoo Connect, um 360°-Bilder hochzuladen.

Klicken Sie auf Cintoo Connect im Dropdown-Menü Werkzeuge oben rechts oder verwenden Sie den folgenden Link, um die neueste Version von Cintoo Connect herunterzuladen.

Dieses Beta-Programm beginnt mit Cintoo Connect Version 1.12.

 

  1. Erstellen Sie eine eigene Arbeitszone, indem Sie auf Arbeitszone im Dropdown-Menü Hinzufügen oben rechts klicken.

     

  2. Öffnen Sie in dieser Arbeitszone die Registerkarte Daten und klicken Sie auf Vorbereiten und importieren auf der Kachel 360°-Bilder oder klicken Sie auf 360°-Bilder im Dropdown-Menü Hinzufügen oben rechts. Cintoo Connect wird gestartet.

     

  3. Aktivieren oder deaktivieren Sie auf der geöffneten Registerkarte 360 Images die Option Blur - Faces:
    • Diese Option ist standardmäßig aktiviert. Wählen Sie die Option None, um keine Unkenntlichmachung anzuwenden.
    • Diese Option macht Gesichter, die auf Panoramabildern in den nach Cintoo hochgeladenen Scans erfasst sind, automatisch unkenntlich.
    • Die Unkenntlichmachung kann in Cintoo nach dem Hochladen der Scans nicht rückgängig gemacht werden.
    • Dateien, die ohne aktivierte Option Blur Faces hochgeladen wurden, müssen aus dem Cintoo-Projekt gelöscht und mit aktivierter Option erneut hochgeladen werden, damit Gesichter automatisch unkenntlich gemacht werden.
  4. Aktivieren oder deaktivieren Sie Blur - Human bodies and car plates:
    • Diese Option ist standardmäßig deaktiviert, die Option Faces ist ausgewählt.
    • Aktivieren Sie diese Option, um menschliche Körper einschließlich Gesichtern und Kfz-Kennzeichen, die auf Panoramabildern in den nach Cintoo hochgeladenen Scans erfasst sind, automatisch unkenntlich zu machen.
    • Die Unkenntlichmachung kann in Cintoo nach dem Hochladen der Scans nicht rückgängig gemacht werden.
    • Dateien, die ohne aktivierte Option Blur Human bodies and car plates hochgeladen wurden, müssen aus dem Cintoo-Projekt gelöscht und mit aktivierter Option erneut hochgeladen werden, damit die automatische Unkenntlichmachung angewendet wird.
Warnung: Verwenden Sie diese Option nur mit Bedacht und nur, wenn es unbedingt erforderlich ist, da sich die Importzeit der Scans bei aktivierter Option verdoppeln kann.
  1. Klicken Sie auf Select 360 Images. Wählen Sie eine CSV-Datei aus, die die sphärischen Bilder auflistet. Die CSV-Datei muss sich im selben Ordner wie die Panoramabilder befinden.

    Die Kapazität des Abonnements für 360°-Bilder wird oben angezeigt.


Anzeige von 360°-Bildern

360°-Bilder werden auf der Registerkarte Daten mit einem eigenen Symbol angezeigt.

 

In der Orthoview und der 3D-Ansicht werden 360°-Bilder als blaugrüne Symbole angezeigt. In der Navigationskarte erscheinen sie als grüne Kreise.

 

Sie können von einem Scan zu einem 360°-Bild, von einem 360°-Bild zu einem anderen 360°-Bild oder von einem 360°-Bild zu einem Scan navigieren.

War dieser Artikel hilfreich?

Das ist großartig!

Vielen Dank für das Feedback

Leider konnten wir nicht helfen

Vielen Dank für das Feedback

Wie können wir diesen Artikel verbessern?

Wählen Sie wenigstens einen der Gründe aus
CAPTCHA-Verifikation ist erforderlich.

Feedback gesendet

Wir wissen Ihre Bemühungen zu schätzen und werden versuchen, den Artikel zu korrigieren