ESRI - Cintoo Experience Builder Widget

この記事では、ESRI Cintoo Experience Builder Widgetを使用して、Cintooプロジェクトのスキャンデータとモデルデータを ESRI 環境に統合し、データをナビゲートして、スキャン情報とモデル情報を比較する方法を説明します。

 


要件とアクセス

  • Cintoo Experience Builder Widget(Experience Builder Developer Editionで作成)は、ArcGIS Enterpriseの11.5以降のバージョンに統合できます
  • 有効なCintooサブスクリプション
  • セキュリティ上の理由から、Widgetをダウンロードする前に、次の情報をsupport@cintoo.comに送信してください。

 

Cintoo Experience Builder Widgetにアクセスするには、ここをクリックしてください

 

注:Widgetの新しいバージョンをインストールする前に、以前のバージョンがキャッシュされないよう、ESRI Portalのキャッシュをクリアしてください。

目次


カスタムCintoo Experience Builder Widgetの追加と統合

  1. 統合を確立するには、手順How to add custom widgetsに従います。このWidgetは追加のコンパイルが不要なため、手順のステップ5は省略できます。
  2. Widget Controllerツールを使用して、すでにMap Widgetがある既存のビルドにCintoo Widgetを統合します。

 

 

 

注:Cintoo Widgetは、あらゆるESRI Experience Builderに追加できます。

 

  1. プロジェクトのニーズに応じて、最も便利な構成で使用してください。
  2. Map Widgetで、Map Widgetに移動して既存のマップを選択するか新しいマップを追加することで、サービスマップをWidgetに追加することを忘れないでください。

     

  3. Web Sceneから、ニーズに合ったマップを選択します。

前提条件

ESRIでCintooプロジェクトを調べる前に、プロジェクトに応じて、座標、または変換の有無を含むCRS(座標参照系)を、Cintooのプロジェクトレベルで定義する必要があります。これにより、スキャンデータをESRI内に正しく配置できます。

 

非測地座標系またはローカルキャリブレーションを使用しているプロジェクトの場合

ユーザーは、プロジェクトの詳細にあるESRIベースマップのピン機能を使用して、プロジェクトの場所を定義できます。この場所が、座標0,0のプロジェクトの原点になります。ユーザーは、ピンを手動で配置するか、緯度と経度の正確な値を入力して精度を高めることができます。

その手順は次のとおりです。

  1. マイプロジェクトで、ESRIで調べるプロジェクトを見つけます。
  2. プロジェクトを編集をクリックします

     

  3. プロジェクトを編集メニューで、座標を選択するか、マップ上の点を選択してから、更新をクリックします。

    同じ設定は、プロジェクトの作成プロセス中にも行えます。

    これらの場合、Cintooがその場でWGS84座標を計算するため、データセットをESRI内に正しく配置できます。

 

特定のEPSG座標系ですでにジオリファレンスされているプロジェクトの場合

プロジェクトがすでに適切にジオリファレンスされている場合、Cintooは、APIを通じて、変換の有無にかかわらず、正しいEPSG IDを埋め込むだけです。そこから、スケール係数や単位系などの必要なパラメーターがすべて使用され、デカルト座標が地理座標に変換されます。これにより、プロジェクトがESRI内の正しい位置に配置されます。

その手順は次のとおりです。

  1. マイプロジェクトで、ESRIで調べるプロジェクトを見つけます。
  2. プロジェクトを編集をクリックします

     

  3. プロジェクトを編集メニューで、座標参照系 フィールドで必要なCRSを選択し、必要に応じて変換を適用してから、更新をクリックします。

    同じ設定は、プロジェクトの作成プロセス中にも行えます。


接続

Cintooアカウントを作成した場所(eu.cintoo.cloud、us.cintoo.cloud、ca.cintoo.cloud、またはカスタムドメイン [companyname].cintoo.cloud)に応じて、正しいTenantの値を入力し、Log in to Cintooをクリックします。

 

Cintooのログインポップアップ(または会社のSSOページ)が表示され、Cintoo(会社)の認証情報を入力してContinueをクリックするよう求められます。

 

次の画面でAllowをクリックして、ESRI WidgetがCintooアカウントのデータを使用することを承認します。

 

メインビューが切り替わり、Accounts(複数ある場合)とProjectsを切り替えるオプションが表示されます。

ドロップダウンメニューから正しいものを選択し、次のいずれかをクリックします。

  • Open in Cintoo:新しいブラウザータブのWebアプリケーションでプロジェクトを開きます
  • Open in ESRI:ESRI Cintoo Experience Builder Widgetを使用します。デフォルトでは1つのワークゾーンが表示されます。

 

右上のLogoutボタンを使用すると、必要に応じてTenant選択メニューに戻ることができます。

上部のプロジェクト名の横にあるアイコンで、プロジェクトコンテンツビューとログインパラメーター(Account、Project)メニューを切り替えます。

 

 

警告:データを空間的に正しく表示するには、前提条件で説明したとおり、CRSが正しく定義されているかどうかを確認してください。

インターフェース

Webアプリケーションのツールおよび機能と、ESRI Cintoo Experience Builder Widget内の対応するものを対比して示します。


Resources Explorer

左上隅にプロジェクトの名前が表示されます。名前の横のボタンで、ログインパラメーター(Account、Project)メニューに移動できます。

 

可視性アイコンをクリックして、スキャンとモデルの表示/非表示をトグルで制御します。

 

表示制御オプションは、ルートワークゾーンを含む各ワークゾーンで利用できます:Show/Hide、Go to、Look at。Webアプリケーションと同様に機能します。

 

注:シーンに必要な数のスキャンだけを表示し、最適なナビゲーション操作性を得られるよう、スキャンとワークゾーンを適宜表示/非表示にします。

Settings

Widgetの右上に、Webアプリケーションにあるものと同様のCintooの機能を備えたSettingsメニューがあります。

 

以下のリンクから、わかりやすいように、CintooのWebアプリケーション内の対応するツールに移動できます。

 

Navigation

  • Scan:スキャンからスキャンへのナビゲーション
  • 3D:3Dナビゲーションモード

 

Color:詳細については、表示モードと表示設定をご覧ください

  • 3D RGB
  • 3D Intensity
  • 3D Surface
  • 2D Panoramic

 

Display Settings:Backface Culling(Display Settings - Backface)。

 

注:Backface Cullingを使用すると、壁や屋根を表示から除外して、ソリッドの建物の内部を確認できます。

Comparison Tool

ESRI Cintoo Experience Builder WidgetのComparison Toolは、Cintooの視覚的差分ツールで表されます。任意のワークゾーン間、またはすべてのモデルとすべてのスキャンモードで、差分をインタラクティブに可視化するために使用します。

 

比較設定の管理

 

Comparison Toolをクリックすると、視覚的差分ツールがデフォルトでオンになり、All Modelsが赤のA、All Scansが緑のBとして設定されます(詳細については、Selecting datasets to compareをご確認ください)。

 

視覚的差分ツールの表示を制御します。

 

  • A:ドロップダウンメニューから色とワークゾーンを選択します。
  • B:ドロップダウンメニューから色とワークゾーンを選択します。
  • プラス記号をクリックすると、AとBの両方の色のカラープリセットを作成できます。プリセットの色を削除するには、マイナス記号をクリックします。
  • スライダーを動かして、データのOpacityを調整します。
    スライダーを左に動かすと、Aとして定義したワークゾーンのコンテンツのみが表示されます。
    スライダーを右に動かすと、Bとして定義したワークゾーンのコンテンツのみが表示されます。

 

Resetボタンは、すべての設定を上記の状態に戻します。つまり、All Modelsが赤のA、All Scansが緑のBで、不透明度は100%です。

 

トグルActivate Comparison Toolで、Comparison Toolのオン/オフを切り替えます。


マップの左上に、Zoom in/out、Toggle to pan in 3D、Toggle to rotation in 3D、Reset map orientationのコントロールがあります。これらは標準のESRI Map Widgetのコントロールです。

  • マウス:
    • パン:スクロールホイールを押したまま、または右クリックしたままマウスをドラッグすると、シーン全体をパンできます。
    • ズーム:マウスホイールをスクロールするか、ナビゲーションコントロールのズームボタンを使用して、ズームレベルを調整します。
    • 回転と傾き:スクロールホイールをクリックしたまま、マウスを上下または左右に動かしてドラッグすると、それぞれカメラが回転し、傾きます。
  • キーボード:
    • パン:矢印キーを使用して、シーンをパンします。
    • ズーム:「+」キーと「-」キー、またはPage Up/Page Downキーを使用して、拡大/縮小します。
    • 回転:A、D、W、Sキー(またはカスタマイズ可能な他のキー)を使用して、カメラを回転させます。
    • 傾き:QキーとEキー(またはカスタマイズ可能な他のキー)を使用して、カメラを傾けます。
    • 上下に移動:UキーとJキーを使用して、カメラを上下に移動し、地面からの高さを調整します。
  • オンスクリーンナビゲーター:
    • パン:ナビゲーターの外側のリングをドラッグして、シーンをパンします。
    • 回転と傾き:ナビゲーターの内側の部分をドラッグして、カメラを回転および傾けます。
    • Show Full Control:Show full controlボタンをクリックして、ナビゲーターのすべての機能にアクセスします。

トラブルシューティング

バグや不整合に遭遇した場合は、製品を共に改善するため、support@cintoo.comまでご連絡ください。

この記事は役に立ちましたか?

それは素晴らしい!

フィードバックありがとうございます

お役に立てず申し訳ございません!

フィードバックありがとうございます

この記事に改善できることがあれば教えてください。

少なくとも一つの理由を選択してください
CAPTCHA認証が必要です。

フィードバックを送信しました

記事の改善におけるご協力ありがとうございます。